Som 5.1

Alguma placa, modem, monitor ou outro hardware/periférico seu não funcionou? Aqui é o seu lugar!

Moderador: Moderadores

Luciano-et
BIGzinho
Mensagens: 8
Registrado em: 26 Jan 2009, 14:16

Som 5.1

Mensagem por Luciano-et » 26 Jan 2009, 14:43

Olá!

Instalei hj o Big Linux 4, por enquanto "ta tudo lindo".
Reconheceu tudo numa boa, porém, minha placa de som é uma Genius Soundmaker Value, chipset C-Media CMI8738, ela é 5.1, mas no BL não está tocando os 5 canais. Aí eu fico sem som na auto falante central e no subwoofer.
Tive esse mesmo problema no Ubuntu, fiz vários tutoriais pra resolver isso com ALSA, mas como sou leigo no linux ñ consegui nada, só resolvi usando o PulseAudio e fazendo uma gambiarra pra funcionar as 6 caixas, aí ficou massa, mas o Ubuntu é lerdo e instável no meu PC.
Alguém tem idéia de como fazer isso no Big usando ALSA? Roda o PulseAudio nele?
Mto obrigado desde já!

Avatar do usuário
lgf
COMPANHEIRO BIG
Mensagens: 368
Registrado em: 10 Out 2008, 08:53

Mensagem por lgf » 27 Jan 2009, 07:27

Se funcionou no ubuntu com o PulseAudio e ficou bom no Big tem que funcionar também

Luciano-et
BIGzinho
Mensagens: 8
Registrado em: 26 Jan 2009, 14:16

Mensagem por Luciano-et » 27 Jan 2009, 08:32

Valeu pela atenção lgf. Vou testar hj e posto aqui o resultado. Meu problema é que pouca gente usa 5.1 no linux (acho eu), aí fica bem difícil arrumar ajuda.

Luciano-et
BIGzinho
Mensagens: 8
Registrado em: 26 Jan 2009, 14:16

Mensagem por Luciano-et » 27 Jan 2009, 21:14

Resolvi em partes meu problema. Segui esse tutorial:
http://www.cse.ohio-state.edu/~bondhugu/alsamch.shtml

Vou dizer o que eu fiz aqui, isso se alguma alma penada entrar nesse tópico abandonado.

1° - crie um arquivo na sua pasta home com esse nome .asoundrc e cole essas linhas:

Código: Selecionar todos

# for 5.1 speakers
pcm.51canais {
         slave.pcm surround51
         slave.channels 6
         type route
         ttable.0.0 1
         ttable.1.1 1
         ttable.0.2 1
         ttable.1.3 1
         ttable.0.4 0.5
         ttable.1.4 0.5
         ttable.0.5 0.5
         ttable.1.5 0.5
}
o termo "51canais" é o nome do dispositivo virtual q criei, pode ser qualquer nome q vc lembre depois. Salve e feche. Entre aqui se quiser entender o ttable http://www.vivaolinux.com.br/artigo/Som ... x?pagina=2

2° - Localize o arquivo rc.local na pasta /etc/, clique com o bt direito do mouse sobre ele e vá em Ações>Abrir com o editor Kate como root e cole isso ENTRE a última linha do arquivo e a linha exit 0.

Código: Selecionar todos

echo Setting 5.1 Channel volumes...
amixer -q set Master 100% unmute 
amixer -q set PCM 60% unmute  
amixer -q set Surround 100% unmute  
amixer -q set "Surround Jack Mode" "Independent"  
amixer -q set Center 81% unmute  
amixer -q set LFE 100% unmute  
amixer -q set "Mic select" "Mic1"   
amixer -q set "Mic" 65% unmute  
amixer -q set "Channel mode" "6ch"   
amixer -q set "Center/LFE Down mix" mute   
amixer -q set "Duplicate Front" mute  
Salve e feche o Kate. Clique novamente com o bt dir do mouse no arquivo rc.local q vc acabou de editar e vá em Ações>Executar no Terminal>Executar no Terminal Fechar em Seguida - COMO ROOT - é importante executar esse arquivo.

3° - Eu uso o Amarok e o Audacious como player.
no Amarok vá em Configurações>Configurar Amarok - na aba Mecanismo, onde diz Plugin de saída coloque alsa - nas opções que tem em Configuração do disposito ALSA no campo Estéreo digite 51canais que é o nosso dispositivo virtual.

no Audacious - CRTL+P na aba Audio clique em Preferências dos Plugins de Saída, em Audio Device digite 51canais

Pronto, agora temos som no auto-falante central e no subwoofer. Mas tem uns problemas:
1- o som sai ruim, pior q no Windows, mas quebra um galho.
2- ñ se ouve 2 sons ao mesmo tempo, tipo qdo está ouvindo música o sistema fica sem som e assim por diante.
3- o sistema continua com som de "2 canais"

Alguém sabe como resolver esses 3 problemas? Pq eu sou completamente leigo em linux. Depois testo com o PulseAudio pra ver se funciona e posto aqui.
Espero ter ajudado alguém![/b]

Luciano-et
BIGzinho
Mensagens: 8
Registrado em: 26 Jan 2009, 14:16

Mensagem por Luciano-et » 27 Jan 2009, 21:24

Resolvi em partes meu problema. Segui esse tutorial:

http://www.cse.ohio-state.edu/~bondhugu/alsamch.shtml

Vou dizer o que eu fiz aqui, caso alguma alma penada entrar nesse tópico abandonado.

1° - crie um arquivo na sua pasta home com esse nome .asoundrc e cole essas linhas:

Código: Selecionar todos

# for 5.1 speakers
pcm.51canais {
         slave.pcm surround51
         slave.channels 6
         type route
         ttable.0.0 1
         ttable.1.1 1
         ttable.0.2 1
         ttable.1.3 1
         ttable.0.4 0.5
         ttable.1.4 0.5
         ttable.0.5 0.5
         ttable.1.5 0.5
}
o termo "51canais" é o nome do dispositivo virtual q criei, pode ser qualquer nome q vc lembre depois. Salve e feche. Entre aqui se quiser entender o ttable
http://www.vivaolinux.com.br/artigo/Som ... x?pagina=2

2° - Localize o arquivo rc.local na pasta /etc/, clique com o bt direito do mouse sobre ele e vá em "Ações>Abrir com o editor Kate como root" e cole isso ENTRE a última linha do arquivo e a linha exit 0.

Código: Selecionar todos

echo Setting 5.1 Channel volumes...
amixer -q set Master 100% unmute 
amixer -q set PCM 60% unmute  
amixer -q set Surround 100% unmute  
amixer -q set "Surround Jack Mode" "Independent"  
amixer -q set Center 81% unmute  
amixer -q set LFE 100% unmute  
amixer -q set "Mic select" "Mic1"   
amixer -q set "Mic" 65% unmute  
amixer -q set "Channel mode" "6ch"   
amixer -q set "Center/LFE Down mix" mute   
amixer -q set "Duplicate Front" mute  
Salve e feche o Kate. Clique novamente com o bt dir do mouse no arquivo rc.local q vc acabou de editar e vá em "Ações>Executar no Terminal>Executar no Terminal Fechar em Seguida - COMO ROOT" é importante executar esse arquivo.

3° - Eu uso o Amarok e o Audacious como player.
no Amarok vá em "Configurações>Configurar Amarok" - na aba "Mecanismo", onde diz "Plugin de saída" coloque alsa - nas opções que tem em "Configuração do disposito ALSA" no campo "Estéreo" digite 51canais que é o nosso dispositivo virtual.

no Audacious - CRTL+P na aba Audio clique em "Preferências dos Plugins de Saída" em "Audio Device" digite 51canais

Pronto, agora temos som no auto-falante central e no subwoofer. Mas tem uns problemas:
1- o som sai ruim, pior q no Windows, mas quebra um galho.
2- ñ se ouve 2 sons ao mesmo tempo, tipo qdo está ouvindo música o sistema fica sem som e assim por diante.
3- o sistema continua com som de "2 canais"

Alguém sabe como resolver esses 3 problemas? Pq eu sou completamente leigo em linux. Depois testo com o PulseAudio pra ver se funciona e posto aqui.
Espero ter ajudado alguém!

toinporco
BIGzinho
Mensagens: 8
Registrado em: 10 Fev 2009, 20:24
Localização: São Paulo/SP - Brasil

Mensagem por toinporco » 11 Fev 2009, 11:11

:D 8) :lol:

Luciano-et, deu certinho aqui!!! Tô felizão. O som fica show, literalmente. Dá de 10 x 2 na 'janela'.

Minha placa é on. Placa mãe é uma Gibabyte GA M61PM-S2.

Cara, valeu mesmo. Vou ver se coloco no wiki.

Trancado

Voltar para “Hardwares e Periféricos”

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 2 visitantes