Problema na inicialização (Grub) com Dual boot Windows

Reporte problemas sobre o boot, instalação ou atualização do BigLinux.

Moderador: Moderadores

Avatar do usuário
the.password
BIG
Mensagens: 34
Registrado em: 14 Ago 2009, 19:35
Localização: Guaratinguetá-SP

Problema na inicialização (Grub) com Dual boot Windows

Mensagem por the.password » 03 Nov 2009, 21:49

Boa Noite,

Eu tenho o Big instalado no meu note em dual boot com o Windows 7 já a algum tempo e nunca tive problemas com ele, instalação o big encontrou sozinho a partição com o seven e colocou a opção lá no grub e eu consigo entrar normalmente.

Um amigo trouxe o notebook aqui em casa para instalarmos o Big também, o note dele (um Dell Inspiron) já tinha o Windows 7 também e ele queria usar em dual.

Como o HD dele era de 320 e estava usando tudo com o Windows, mandei o particionador gráfico do big diminuir para sobrar 40Gb no final para o Linux, e criei uma partição lá. Apesar do particionamento ter demorado quase 12 horas, mas correu tudo bem, a instalação foi super rápida e tudo funcionou normalmente. Inclusive a partição do Windows que abre no linux normalmente e até com opção de leitura e escrita.

Acontece que, ao tentarmos entrar no Windows pelo grub nas opções de inicialização, ele mostra a seguinte mensagem:

root (hd0,2)
Filesystem type unknow, partition type 0x7
savedefault
chainloader +1


Já procurei em alguns fóruns por ai e em um caso que achei não encontrei solução para o caso e numa dedução um pouco prematura ainda do caso, penso até se não é problema de hardware não compatível com o grub ou algo do tipo... Isso seria possível?

Alguém já passou por algo parecido ou tem alguma dica do que fazer?

Obrigado.


PS.: Será que usando o DVD do windows 7 e pedindo pra restaurar (não olhei as opções de reparo dele ainda) ele volta com o Windows e elimina o grub e depois posso procurar uma alternativa ao grub ou outra solução possível?

Obrigado pela atenção.
Note: LG V1 - Celeron M / 1G / 80G / ATI XPRESS 200M
- Win7
- BIGLinux

Desktop: P E7200 / 4G / 500G / GF 8500GT
- Win 7 - Dx 10

Avatar do usuário
Jorgebadad
Big Moderador!
Mensagens: 4219
Registrado em: 23 Fev 2008, 17:17
Localização: Manaus-AM

Mensagem por Jorgebadad » 03 Nov 2009, 22:05

the.password;

Sistema windows precisa desfragmentar de tempos em tempos para organizar suas estantes de arquivos, por isso antes de mexer numa partição windows, precisa desfragmentar, e depois proceder à instalação do Big...

Bom, como já particionou, recupere o MBR do windows, usando o CD, deixe ele bootável novamente, depois coloque o CD do Big na bandeja e reinicie o sistema pelo botão iniciar do windows, nunca pelo botão reset, reinstale o Big, aceite usar o GRUB no MBR, não crie disquete de boot, que tudo vai dar certo...

Avatar do usuário
the.password
BIG
Mensagens: 34
Registrado em: 14 Ago 2009, 19:35
Localização: Guaratinguetá-SP

Mensagem por the.password » 04 Nov 2009, 00:15

Jorgebadad escreveu:the.password;

Sistema windows precisa desfragmentar de tempos em tempos para organizar suas estantes de arquivos, por isso antes de mexer numa partição windows, precisa desfragmentar, e depois proceder à instalação do Big...

Bom, como já particionou, recupere o MBR do windows, usando o CD, deixe ele bootável novamente, depois coloque o CD do Big na bandeja e reinicie o sistema pelo botão iniciar do windows, nunca pelo botão reset, reinstale o Big, aceite usar o GRUB no MBR, não crie disquete de boot, que tudo vai dar certo...
:x Realmente, quando eu instalei o Big no meu note eu tinha desfragmentado a hd antes de reparticionar... mas nesse note do meu amigo eu nem lembrei disso... mancada minha...

Eu vou fazer isso, quando terminar aviso aqui se deu certo...

Obrigado pelas dicas... :)
Note: LG V1 - Celeron M / 1G / 80G / ATI XPRESS 200M
- Win7
- BIGLinux

Desktop: P E7200 / 4G / 500G / GF 8500GT
- Win 7 - Dx 10

paulo iamanaka
BIGzinho
Mensagens: 6
Registrado em: 04 Nov 2009, 17:08

Mensagem por paulo iamanaka » 04 Nov 2009, 17:17

Opa, está aqui o amigo!

Este note é meu! E a batalha continua!! :o :shock:

Então, Jorge, fiz o que estava indicado (e mais outras coisinhas). Realmente o boot do windows se perdeu, mas a correção foi feita com sucesso (segundo o windows). Mas o GRUB não larga o boot da máquina. Então, o problema continuou já que é o GRUB que não consegue carregar o Windows...

Tentei reinstalar o Big Linux, usando GRUB e LILO, mas nada feito.

A Restauração do Windows 7 não funciona.

Estou começando a pensar em formatação geral... mas não queria fazer isso não.

Por enquanto é só, se alguém souber de algo.


Abraços!

Avatar do usuário
andre.also7
Big Moderador!
Mensagens: 2630
Registrado em: 23 Mai 2008, 15:03
Localização: São Paulo, Interlagos - Brasil
Contato:

Mensagem por andre.also7 » 04 Nov 2009, 17:21

:arrow: Para recuperar o bootloader do Windows 7

bcdedit /set {current} locale pt-BR
ou
bcdboot %WinDir% /l pt-BR

:arrow: Para recuperar o GRUB do Linux

$ sudo -s
# mkdir /media/sda2 (sda2 é a partição onde está o BigLinux)
# mount /dev/sda2 /media/sda2
# mount -o bind /dev/ /media/sda2/dev
# grub-install --root-directory =/media/sda2 /dev/sda


-----------------

Estou colocando aqui pois eu tive problemas com a perda do GRUB após instalar o Windows Seven.

paulo iamanaka
BIGzinho
Mensagens: 6
Registrado em: 04 Nov 2009, 17:08

Mensagem por paulo iamanaka » 04 Nov 2009, 17:48

André.

Tentei recuperar o boot do Windows 7 com estes comandos.
Mas nenhum funcionou.

O Big Linux entra normalmente.

E valeu desde já.

Avatar do usuário
the.password
BIG
Mensagens: 34
Registrado em: 14 Ago 2009, 19:35
Localização: Guaratinguetá-SP

Mensagem por the.password » 05 Nov 2009, 11:14

Oi...

Estou baixando o BigLinux 5 Alpha 3, ele usa o isolinux como bootloader, será que ele é melhor? Dá pra instalar pelo live CD apenas o bootloader sem precisar instalar o sistema novamente?


Vou testar ele a noite se conseguir tempo...
Note: LG V1 - Celeron M / 1G / 80G / ATI XPRESS 200M
- Win7
- BIGLinux

Desktop: P E7200 / 4G / 500G / GF 8500GT
- Win 7 - Dx 10

Avatar do usuário
Trovador Solitario
BIG! BIG!
Mensagens: 133
Registrado em: 23 Set 2009, 08:04
Contato:

Mensagem por Trovador Solitario » 06 Nov 2009, 04:35

the.password escreveu:Oi...

Estou baixando o BigLinux 5 Alpha 3, ele usa o isolinux como bootloader, será que ele é melhor? Dá pra instalar pelo live CD apenas o bootloader sem precisar instalar o sistema novamente?


Vou testar ele a noite se conseguir tempo...
será para testes ou como sistema definitivo? se for definitivo, fique com o BL 4.2
Acesse:
http://euprimata.blogspot.com/
AMD Phenom II X4 945 - 3.0Ghz
2Gb DDRIII
Asus M4785TD-V EVO
Windows 7 + Kubuntu + 98 + ME

paulo iamanaka
BIGzinho
Mensagens: 6
Registrado em: 04 Nov 2009, 17:08

Mensagem por paulo iamanaka » 06 Nov 2009, 10:08

Trovador...

A questão nem é o BL...

A questão é um bootloader que corrija algo que não deu certo. Não deu, as orientações que encontramos na internet não resolvem, e alguns profissionais que entendem de linux não estão conseguindo corrigir...

Na verdade, acho que tentar o isolinux é a ultima tentativa... talvez o Windows tenha se corrompido no processo de particionamento.

Responder

Voltar para “Instalação e Atualização”

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 5 visitantes